nanoc安装

nanoc是一个ruby程序,因此首先安装ruby:

sudo apt-get install ruby

注意ruby的版本应该是1.9.3以上,安装完检查一下。然后安装nanoc:

sudo gem install nanoc

注意,如果这一步无法安装,可能是应为安装源不能访问的原因,这时可以切换到国内的安装源镜像:

gem sources --remove https://rubygems.org/
gem sources -a http://ruby.taobao.org/
gem sources -l

如果要在本地调试,需要安装一个小型的web服务器:

gem install adsf

安装后就可以启动服务器,查看页面:

nanoc view

默认情况下只支持html文件格式,还可以通过安装程序获得Markdown格式支持:

gem install kramdown